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Android	Studio	menyediakan	wizard	dan	template	yang	memverifikasi	persyaratan	sistem	Anda,	seperti	Java	Development	Kit	(JDK)	dan	RAM	yang	tersedia,	serta	mengonfigurasi	setelan	default,	seperti	emulasi	Android	Virtual	Device	(AVD)	default	yang	dioptimalkan	dan	image	sistem	yang	telah	diperbarui.	Dokumen	ini	menjelaskan	setelan
konfigurasi	tambahan	yang	mungkin	dapat	Anda	gunakan	untuk	menyesuaikan	penggunaan	Android	Studio.	Android	Studio	menyediakan	akses	ke	dua	file	konfigurasi	melalui	menu	Help:	studio.vmoptions:	Menyesuaikan	opsi	untuk	Java	Virtual	Machine	(JVM)	di	Studio,	misalnya	ukuran	heap	dan	ukuran	cache.	Perhatikan	bahwa	di	mesin	Linux,	file
ini	mungkin	bernama	studio64.vmoptions,	bergantung	pada	versi	Android	Studio	Anda.	idea.properties:	Menyesuaikan	properti	Android	Studio,	misalnya	jalur	folder	plugin	atau	ukuran	file	maksimum	yang	didukung.	Untuk	dokumentasi	khusus	tentang	emulator	serta	penyiapan	dan	penggunaan	perangkat,	lihat	topik	berikut:	Mengelola	perangkat
virtual	Menggunakan	perangkat	hardware	Driver	USB	OEM	Menemukan	file	konfigurasi	Anda	Kedua	file	konfigurasi	disimpan	di	folder	konfigurasi	untuk	Android	Studio.	Nama	folder	bergantung	pada	versi	Studio	Anda.	Misalnya,	Android	Studio	3.3	memiliki	nama	folder	AndroidStudio3.3.	Lokasi	folder	ini	bergantung	pada	sistem	operasi	Anda:
Windows:	%USERPROFILE%\.CONFIGURATION_FOLDER	macOS:	~/Library/Preferences/CONFIGURATION_FOLDER	Linux:	~/.CONFIGURATION_FOLDER	Anda	juga	dapat	menggunakan	variabel	lingkungan	berikut	untuk	menunjuk	ke	file	pengganti	spesifik	di	tempat	lain:	STUDIO_VM_OPTIONS:	menetapkan	nama	dan	lokasi	file	.vmoptions
STUDIO_PROPERTIES:	menetapkan	nama	dan	lokasi	file	.properties	STUDIO_JDK:	menetapkan	JDK	yang	digunakan	untuk	menjalankan	Studio	Menyesuaikan	opsi	VM	Anda	File	studio.vmoptions	memungkinkan	Anda	menyesuaikan	opsi	untuk	JVM	di	Android	Studio.	Untuk	meningkatkan	performa	Studio,	opsi	paling	umum	yang	biasa	disesuaikan
adalah	ukuran	heap	maksimum,	tetapi	Anda	juga	dapat	menggunakan	file	studio.vmoptions	untuk	menggantikan	setelan	default	lainnya	seperti	ukuran	heap	awal,	ukuran	cache,	dan	switch	pengumpulan	sampah	Java.	Untuk	membuat	file	studio.vmoptions	baru	atau	membuka	file	yang	sudah	ada,	gunakan	langkah	berikut:	Klik	Help	>	Edit	Custom	VM
Options.	Jika	Anda	belum	pernah	mengedit	opsi	VM	untuk	Android	Studio	sebelumnya,	IDE	akan	meminta	Anda	membuat	file	studio.vmoptions	baru.	Untuk	membuat	file,	klik	Yes.	File	studio.vmoptions	akan	terbuka	di	jendela	editor	Android	Studio.	Edit	file	tersebut	untuk	menambahkan	opsi	VM	yang	Anda	sesuaikan	sendiri.	Untuk	daftar	lengkap
opsi	JVM	yang	dapat	disesuaikan,	lihat	halaman	Java	HotSpot	VM	Options	dari	Oracle.	File	studio.vmoptions	yang	Anda	buat	akan	ditambahkan	ke	file	studio.vmoptions	default,	yang	berada	di	direktori	bin/	dalam	folder	penginstalan	Android	Studio.	Perhatikan,	Anda	tidak	boleh	secara	langsung	mengedit	file	studio.vmoptions	yang	ditemukan	dalam
folder	program	Android	Studio.	Meskipun	Anda	dapat	mengakses	file	tersebut	untuk	menampilkan	opsi	VM	default	Studio,	dengan	hanya	mengedit	file	studio.vmoptions	sendiri	akan	memastikan	bahwa	Anda	tidak	menggantikan	setelan	default	penting	untuk	Android	Studio.	Oleh	karena	itu,	pada	file	studio.vmoptions,	hanya	ganti	atribut	yang
diperlukan	dan	biarkan	Android	Studio	tetap	menggunakan	nilai	default	untuk	atribut	yang	belum	Anda	ubah.	Ukuran	heap	maksimum	Secara	default,	Android	Studio	memiliki	ukuran	heap	maksimum	1.280	MB.	Jika	menangani	project	besar,	atau	sistem	Anda	memiliki	RAM	yang	besar,	Anda	dapat	meningkatkan	performa	dengan	meningkatkan
ukuran	heap	maksimum	untuk	proses	Android	Studio,	seperti	IDE	inti,	daemon	Gradle,	dan	daemon	Kotlin.	Android	Studio	otomatis	memeriksa	kemungkinan	pengoptimalan	ukuran	heap	dan	memberi	tahu	Anda	jika	mendeteksi	bahwa	performa	dapat	ditingkatkan.	Gambar	1.	Notifikasi	terkait	setelan	memori	yang	direkomendasikan.	Jika
menggunakan	sistem	64	bit	yang	memiliki	RAM	minimal	5	GB,	Anda	juga	dapat	menyesuaikan	ukuran	heap	untuk	project	secara	manual.	Untuk	melakukannya,	ikuti	langkah	berikut:	Klik	File	>	Settings	dari	panel	menu	(atau	Android	Studio	>	Preferences	di	macOS).	Klik	Appearance	&	Behavior	>	System	Settings	>	Memory	Settings.	Sesuaikan
ukuran	heap	agar	cocok	dengan	jumlah	yang	Anda	inginkan.	Klik	Apply.	Jika	mengubah	ukuran	heap	untuk	IDE,	Anda	harus	memulai	ulang	Android	Studio	sebelum	setelan	memori	baru	diterapkan.	Catatan:Mengalokasikan	terlalu	banyak	memori	dapat	menurunkan	performa.	Mengekspor	dan	mengimpor	setelan	IDE	Anda	dapat	mengekspor	file
Settings.jar	yang	berisi	semua	atau	sebagian	setelan	IDE	yang	dipilih	untuk	project.	Selanjutnya,	Anda	dapat	mengimpor	file	JAR	ini	ke	dalam	project	lain	dan/atau	menyediakannya	untuk	diimpor	kolega	Anda	ke	dalam	project	mereka.	Untuk	informasi	selengkapnya,	lihat	Mengekspor	dan	Mengimpor	Setelan	di	IntelliJ	IDEA.	Menyesuaikan	properti
IDE	Anda	File	idea.properties	memungkinkan	Anda	menyesuaikan	properti	IDE	untuk	Android	Studio,	misalnya	jalur	ke	plugin	yang	diinstal	pengguna	dan	ukuran	file	maksimum	yang	didukung	oleh	IDE.	File	idea.properties	akan	digabung	dengan	properti	default	untuk	IDE,	jadi	Anda	dapat	menetapkan	properti	pengganti	saja.	Untuk	membuat	file
idea.properties	baru	atau	membuka	file	yang	sudah	ada,	gunakan	langkah	berikut:	Klik	Help	>	Edit	Custom	Properties.	Jika	belum	pernah	mengedit	properti	IDE	sebelumnya,	Android	Studio	akan	meminta	Anda	untuk	membuat	file	idea.properties	baru.	Untuk	membuat	file,	klik	Yes.	File	idea.properties	akan	terbuka	di	jendela	editor	Android	Studio.
Edit	file	tersebut	untuk	menambahkan	properti	IDE	yang	telah	Anda	sesuaikan	sendiri.	File	idea.properties	berikut	menyertakan	properti	IDE	yang	biasanya	disesuaikan.	Untuk	daftar	lengkap	properti,	baca	tentang	idea.properties	file	untuk	IntelliJ	IDEA.	#---------------------------------------------------------------------	#	Uncomment	this	option	if	you	want	to
customize	path	to	user	installed	plugins	folder.	Make	sure	#	you're	using	forward	slashes.	#---------------------------------------------------------------------	#	idea.plugins.path=${idea.config.path}/plugins	#---------------------------------------------------------------------	#	Maximum	file	size	(kilobytes)	IDE	should	provide	code	assistance	for.	#	The	larger	file	is	the	slower	its	editor
works	and	higher	overall	system	memory	requirements	are	#	if	code	assistance	is	enabled.	Remove	this	property	or	set	to	very	large	number	if	you	need	#	code	assistance	for	any	files	available	regardless	their	size.	#---------------------------------------------------------------------	idea.max.intellisense.filesize=2500	#---------------------------------------------------------------------	#
This	option	controls	console	cyclic	buffer:	keeps	the	console	output	size	not	higher	than	the	#	specified	buffer	size	(Kb).	Older	lines	are	deleted.	In	order	to	disable	cycle	buffer	use	#	idea.cycle.buffer.size=disabled	#---------------------------------------------------------------------	idea.cycle.buffer.size=1024	#---------------------------------------------------------------------	#	Configure
if	a	special	launcher	should	be	used	when	running	processes	from	within	IDE.	#	Using	Launcher	enables	"soft	exit"	and	"thread	dump"	features	#---------------------------------------------------------------------	idea.no.launcher=false	#---------------------------------------------------------------------	#	To	avoid	too	long	classpath	#---------------------------------------------------------------------
idea.dynamic.classpath=false	#---------------------------------------------------------------------	#	There	are	two	possible	values	of	idea.popup.weight	property:	"heavy"	and	"medium".	#	If	you	have	WM	configured	as	"Focus	follows	mouse	with	Auto	Raise"	then	you	have	to	#	set	this	property	to	"medium".	It	prevents	problems	with	popup	menus	on	some	#
configurations.	#---------------------------------------------------------------------	idea.popup.weight=heavy	#---------------------------------------------------------------------	#	Use	default	anti-aliasing	in	system,	i.e.	override	value	of	#	"Settings|Editor|Appearance|Use	anti-aliased	font"	option.	May	be	useful	when	using	Windows	#	Remote	Desktop	Connection	for	instance.	#-----------------
----------------------------------------------------	idea.use.default.antialiasing.in.editor=false	#---------------------------------------------------------------------	#	Disabling	this	property	may	lead	to	visual	glitches	like	blinking	and	fail	to	repaint	#	on	certain	display	adapter	cards.	#---------------------------------------------------------------------	sun.java2d.noddraw=true	#-------------------------------------------
--------------------------	#	Removing	this	property	may	lead	to	editor	performance	degradation	under	Windows.	#---------------------------------------------------------------------	sun.java2d.d3d=false	#---------------------------------------------------------------------	#	Workaround	for	slow	scrolling	in	JDK6	#---------------------------------------------------------------------	swing.bufferPerWindow=false	#---------
------------------------------------------------------------	#	Removing	this	property	may	lead	to	editor	performance	degradation	under	X	Window.	#---------------------------------------------------------------------	sun.java2d.pmoffscreen=false	#---------------------------------------------------------------------	#	Workaround	to	avoid	long	hangs	while	accessing	clipboard	under	Mac	OS	X.	#----------------------
-----------------------------------------------	#	ide.mac.useNativeClipboard=True	#---------------------------------------------------------------------	#	Maximum	size	(kilobytes)	IDEA	will	load	for	showing	past	file	contents	-	#	in	Show	Diff	or	when	calculating	Digest	Diff	#---------------------------------------------------------------------	#	idea.max.vcs.loaded.size.kb=20480	Mengonfigurasi	IDE	untuk
komputer	dengan	memori	rendah	Jika	Anda	menjalankan	Android	Studio	di	komputer	yang	spesifikasinya	lebih	rendah	daripada	yang	direkomendasikan	(lihat	Persyaratan	Sistem),	Anda	dapat	menyesuaikan	IDE	untuk	meningkatkan	performa	di	komputer	Anda,	dengan	cara	sebagai	berikut:	Kurangi	ukuran	heap	maksimum	yang	tersedia	untuk
Android	Studio:	Kurangi	ukuran	heap	maksimum	untuk	Android	Studio	menjadi	512	Mb.	Untuk	informasi	selengkapnya	tentang	perubahan	ukuran	heap	maksimum,	lihat	Ukuran	heap	maksimum.	Update	Gradle	dan	plugin	Android	untuk	Gradle:	Update	Gradle	dan	plugin	Android	untuk	Gradle	ke	versi	terbarunya	untuk	memastikan	Anda
memanfaatkan	peningkatan	performa	terbaru.	Untuk	informasi	selengkapnya	tentang	mengupdate	Gradle	dan	plugin	Android	untuk	Gradle,	lihat	Catatan	Rilis	plugin	Android	untuk	Gradle.	Aktifkan	Mode	Hemat	Daya:	Mengaktifkan	Mode	Hemat	Daya	akan	menonaktifkan	sejumlah	operasi	latar	belakang	yang	boros	memori	dan	baterai,	termasuk
penyorotan	error	dan	inspeksi	sambil	menjalankan	proses,	pop-up	pelengkapan	kode	otomatis,	dan	kompilasi	latar	belakang	inkremental	otomatis.	Untuk	mengaktifkan	Mode	Hemat	Daya,	klik	File	>	Power	Save	Mode.	Nonaktifkan	pemeriksaan	lint	yang	tidak	perlu:	Untuk	mengubah	pemeriksaan	lint	mana	yang	dijalankan	Android	Studio	pada	kode
Anda,	lakukan	langkah	berikut:	Untuk	membuka	dialog	Settings,	klik	File	>	Settings	(di	macOS,	Android	Studio	>	Preferences).	Di	panel	kiri,	luaskan	bagian	Editor,	lalu	klik	Inspections.	Klik	kotak	centang	untuk	memilih	atau	membatalkan	pilihan	pemeriksaan	lint	sesuai	dengan	project	Anda.	Untuk	menyimpan	perubahan,	klik	Apply	atau	OK.
Jalankan	debug	di	perangkat	fisik:	Menjalankan	debug	di	emulator	yang	menggunakan	lebih	banyak	memori	daripada	di	perangkat	fisik,	sehingga	Anda	dapat	meningkatkan	performa	keseluruhan	untuk	Android	Studio	dengan	menjalankan	debug	di	perangkat	fisik.	Hanya	sertakan	layanan	Google	Play	yang	diperlukan	sebagai	dependensi:
Menyertakan	Layanan	Google	Play	sebagai	dependensi	dalam	project	Anda	akan	meningkatkan	jumlah	memori	yang	diperlukan.	Sertakan	hanya	dependensi	yang	diperlukan	untuk	meningkatkan	penggunaan	memori	dan	performa.	Untuk	informasi	selengkapnya,	lihat	Menambahkan	Layanan	Google	Play	ke	Project	Anda.	Aktifkan	Offline	Mode	untuk
Gradle:	Jika	bandwidth	Anda	terbatas,	aktifkan	Offline	Mode	untuk	mencegah	Gradle	mendownload	dependensi	yang	terlewatkan	selama	proses	build.	Jika	Offline	Mode	diaktifkan,	Gradle	akan	mengeluarkan	peringatan	kegagalan	proses	build	jika	Anda	melewatkan	suatu	dependensi,	bukannya	mencoba	mendownload	dependensi	tersebut.	Untuk
mengaktifkan	Offline	Mode,	lakukan	langkah	berikut	ini:	Untuk	membuka	dialog	Settings,	klik	File	>	Settings	(di	macOS,	Android	Studio	>	Preferences).	Di	panel	kiri,	luaskan	Build,	Execution,	Deployment,	lalu	klik	Gradle.	Pada	setelan	Global	Gradle,	centang	kotak	Offline	work.	Klik	Apply	atau	OK	untuk	menerapkan	perubahan.	Kurangi	ukuran	heap
maksimum	yang	tersedia	untuk	Gradle:	Ukuran	heap	maksimum	default	Gradle	adalah	1.536	MB.	Kurangi	nilai	ini	dengan	mengganti	properti	org.gradle.jvmargs	pada	file	gradle.properties,	seperti	ditunjukkan	di	bawah:	#	Make	sure	to	gradually	decrease	this	value	and	note	#	changes	in	performance.	Allocating	too	little	memory	may	#	also
decrease	performance.	org.gradle.jvmargs	=	-Xmx1536m	Jangan	aktifkan	parallel	compilation:	Android	Studio	dapat	mengompilasi	modul	independen	secara	paralel,	tetapi	jika	sistem	Anda	memiliki	memori	yang	rendah,	sebaiknya	jangan	aktifkan	fitur	ini.	Untuk	memeriksa	setelan	ini,	lakukan	hal	berikut:	Untuk	membuka	dialog	Settings,	klik	File	>
Settings	(di	macOS,	Android	Studio	>	Preferences).	Di	panel	kiri,	luaskan	Build,	Execution,	Deployment,	lalu	klik	Compiler.	Pastikan	opsi	Compile	independent	modules	in	parallel	tidak	dicentang.	Jika	Anda	telah	membuat	perubahan,	klik	Apply	atau	OK	untuk	menerapkan	perubahan.	Menyetel	versi	JDK	Salinan	OpenJDK	terbaru	dilengkapi	dengan
Android	Studio	2.2	dan	yang	lebih	baru,	dan	inilah	versi	JDK	yang	kami	sarankan	untuk	digunakan	pada	project	Android	Anda.	Untuk	menggunakan	JDK	yang	disertakan,	lakukan	langkah	berikut:	Di	panel	menu,	buka	project	Anda	di	Android	Studio,	lalu	pilih	File	>	Project	Structure.	Pada	halaman	SDK	Location	di	JDK	location,	centang	kotak	Use
embedded	JDK.	Klik	OK.	Secara	default,	versi	bahasa	Java	yang	digunakan	untuk	mengompilasi	project	Anda	didasarkan	pada	compileSdkVersion	project	(karena	versi	Android	yang	berbeda	mendukung	versi	Java	yang	berbeda	pula).	Jika	perlu,	Anda	dapat	mengganti	versi	Java	default	ini	dengan	menambahkan	blok	CompileOptions	{}	berikut	ke	file
build.gradle:	android	{	compileOptions	{	sourceCompatibility	JavaVersion.VERSION\_1\_6	targetCompatibility	JavaVersion.VERSION\_1\_6	}	}	Untuk	informasi	selengkapnya	tentang	tempat	compileSdkVersion	didefinisikan,	baca	tentang	file	build	level	modul.	Menyetel	setelan	proxy	Proxy	berfungsi	sebagai	koneksi	perantara	antara	klien	HTTP	dan
server	web	yang	menambah	keamanan	dan	privasi	ke	koneksi	internet.	Agar	Android	Studio	dapat	dijalankan	di	belakang	firewall,	atur	setelan	proxy	untuk	Android	Studio	IDE.	Gunakan	halaman	setelan	Proxy	HTTP	Android	Studio	IDE	untuk	mengatur	setelan	proxy	HTTP	untuk	Android	Studio.	Saat	menjalankan	plugin	Android	untuk	Gradle	dari
command	line	atau	pada	komputer	yang	tidak	terinstal	Android	Studio,	seperti	server	continuous	integration,	tetapkan	setelan	proxy	dalam	file	build	Gradle.	Catatan:	Setelah	penginstalan	awal	paket	Android	Studio,	Android	Studio	dapat	berjalan	dengan	atau	tanpa	akses	internet.	Namun,	Android	Studio	memerlukan	sambungan	internet	untuk
sinkronisasi	Setup	Wizard,	akses	library	pihak	ketiga,	akses	ke	repositori	jarak	jauh,	inisialisasi	dan	sinkronisasi	Gradle,	serta	update	versi	Android	Studio.	Mempersiapkan	proxy	Android	Studio	Android	Studio	mendukung	setelan	proxy	HTTP	sehingga	Anda	dapat	menjalankan	Android	Studio	di	belakang	firewall	atau	jaringan	aman.	Untuk
menetapkan	setelan	proxy	HTTP	dalam	Android	Studio:	Dari	panel	menu,	klik	File	>	Settings	(di	macOS,	klik	Android	Studio	>	Preferences).	Di	panel	kiri,	klik	Appearance	&	Behavior	>	System	Settings	>	HTTP	Proxy.	Halaman	Proxy	HTTP	akan	muncul.	Pilih	Auto-detect	proxy	settings	agar	Anda	dapat	menggunakan	URL	konfigurasi	proxy	otomatis
untuk	setelan	proxy,	atau	Manual	proxy	configuration	untuk	memasukkan	sendiri	setiap	setelan.	Untuk	penjelasan	mendetail	mengenai	setelan	ini,	lihat	Proxy	HTTP.	Klik	Apply	atau	OK	untuk	menerapkan	perubahan.	Setelan	proxy	HTTP	plugin	Android	untuk	Gradle	Saat	menjalankan	plugin	Android	untuk	Gradle	dari	command	line	atau	pada
komputer	yang	tidak	terinstal	Android	Studio,	tetapkan	setelan	proxy	plugin	Android	untuk	Gradle	dalam	file	build	Gradle.	Untuk	setelan	proxy	HTTP	spesifik-aplikasi,	tetapkan	setelan	proxy	dalam	file	build.gradle	sebagaimana	diperlukan	untuk	setiap	modul	aplikasi.	apply	plugin:	'com.android.application'	android	{	...	defaultConfig	{	...
systemProp.http.proxyHost=proxy.company.com	systemProp.http.proxyPort=443	systemProp.http.proxyUser=userid	systemProp.http.proxyPassword=password	systemProp.http.auth.ntlm.domain=domain	}	...	}	Untuk	setelan	proxy	HTTP	lingkup-project,	tetapkan	setelan	proxy	dalam	file	gradle/gradle.properties.	#	Project-wide	Gradle	settings.	...
systemProp.http.proxyHost=proxy.company.com	systemProp.http.proxyPort=443	systemProp.http.proxyUser=username	systemProp.http.proxyPassword=password	systemProp.http.auth.ntlm.domain=domain	systemProp.https.proxyHost=proxy.company.com	systemProp.https.proxyPort=443	systemProp.https.proxyUser=username
systemProp.https.proxyPassword=password	systemProp.https.auth.ntlm.domain=domain	...	Informasi	tentang	penggunaan	properti	Gradle	untuk	setelan	proxy	dapat	dilihat	di	Panduan	Pengguna	Gradle.	Note:	Saat	menggunakan	Android	Studio,	setelan	pada	halaman	setelan	proxy	HTTP	IDE	Android	Studio	akan	mengganti	setelan	proxy	HTTP	pada
file	gradle.properties.	Mengoptimalkan	performa	Android	Studio	di	Windows	Performa	Android	Studio	di	Windows	dapat	dipengaruhi	oleh	berbagai	faktor.	Bagian	ini	menjelaskan	cara	mengoptimalkan	setelan	Android	Studio	untuk	mendapatkan	performa	terbaik	di	Windows.	Meminimalkan	dampak	software	antivirus	pada	kecepatan	build	Beberapa
software	antivirus	dapat	mengganggu	proses	build	Android	Studio,	yang	menyebabkan	build	berjalan	sangat	lambat.	Saat	Anda	menjalankan	build	di	Android	Studio,	Gradle	mengompilasi	resource	dan	kode	sumber	aplikasi	Anda,	lalu	memaketkan	resource	yang	telah	dikompilasi	bersama-sama	ke	dalam	sebuah	APK.	Selama	proses	ini,	banyak	file
dibuat	di	komputer	Anda.	Jika	software	antivirus	Anda	mengaktifkan	pemindaian	real-time,	antivirus	dapat	memaksa	proses	build	untuk	berhenti	setiap	kali	file	dibuat	saat	antivirus	memindai	file	tersebut.	Untuk	menghindari	masalah	ini,	Anda	dapat	mengecualikan	direktori	tertentu	dari	pemindaian	real-time	dalam	software	antivirus.	Perhatian:
Untuk	memastikan	keamanan	komputer	Anda	dari	software	berbahaya,	sebaiknya	jangan	nonaktifkan	pemindaian	real-time	atau	software	antivirus	sepenuhnya.	Daftar	berikut	menunjukkan	lokasi	default	setiap	direktori	Android	Studio	yang	sebaiknya	Anda	kecualikan	dari	pemindaian	real-time:	Cache	Gradle	%USERPROFILE%\.gradle	Project
Android	Studio	%USERPROFILE%\AndroidStudioProjects	Android	SDK	%USERPROFILE%\AppData\Local\Android\SDK	File	sistem	Android	Studio	%USERPROFILE%\.AndroidStudio\system	Menyesuaikan	lokasi	direktori	untuk	lingkungan	terkontrol	Kebijakan	Grup	Jika	Kebijakan	Grup	membatasi	direktori	yang	dapat	dikecualikan	dari	pemindaian
real-time	di	komputer,	Anda	dapat	memindahkan	direktori	Android	Studio	ke	salah	satu	lokasi	yang	tidak	termasuk	dalam	Kebijakan	Grup	terpusat.	Daftar	berikut	menunjukkan	cara	menyesuaikan	lokasi	setiap	direktori	Android	Studio,	dengan	C:\WorkFolder	adalah	direktori	yang	sudah	dikecualikan	oleh	Kebijakan	Grup	Anda:	Cache	Gradle	Tentukan
variabel	lingkungan	GRADLE_USER_HOME	agar	menunjuk	ke	C:\WorkFolder\.gradle.	Project	Android	Studio	Pindahkan	atau	buat	direktori	project	dalam	subdirektori	yang	sesuai	untuk	C:\WorkFolder.	Contohnya,	C:\WorkFolder\AndroidStudioProjects.	Android	SDK	Ikuti	langkah	berikut:	Di	Android	Studio,	buka	dialog	Settings	(Preferences	di
macOS),	lalu	buka	Appearance	&	Behavior	>	System	Settings	>	Android	SDK.	Ubah	nilai	Android	SDK	Location	menjadi	C:\WorkFolder\AndroidSDK.	Agar	tidak	mendownload	SDK	ini	lagi,	pastikan	untuk	menyalin	direktori	SDK	yang	sudah	ada,	yang	secara	default	terletak	di	%USERPROFILE%\AppData\Local\Android\SDK,	ke	lokasi	baru.	File	sistem
Android	Studio	Ikuti	langkah	berikut:	Di	Android	Studio,	klik	Help	>	Edit	Custom	Properties.	Android	Studio	akan	meminta	Anda	membuat	file	idea.properties	jika	Anda	belum	memilikinya.	Tambahkan	baris	berikut	ke	file	idea.properties	Anda:	idea.system.path=c:/workfolder/studio/caches/trunk-system	Mengonfigurasi	dependensi	build	offline	Jika
Anda	ingin	membuat	project	tanpa	koneksi	jaringan,	ikuti	langkah-langkah	di	bawah	untuk	mengonfigurasi	IDE	agar	dapat	menggunakan	Plugin	Android	Gradle	dan	dependensi	Google	Maven	versi	offline.	Jika	Anda	belum	melakukannya,	download	komponen	offline	dari	halaman	download.	Mendownload	dan	mengekstrak	komponen	offline	Setelah
Anda	mendownload	komponen	offline,	ekstrak	isinya	ke	dalam	direktori	berikut,	yang	mungkin	perlu	Anda	buat	jika	belum	ada:	Pada	Windows:	%USER_HOME%/.android/manual-offline-m2/	Pada	macOS	dan	Linux:	~/.android/manual-offline-m2/	Untuk	mengupdate	komponen	offline,	lakukan	langkah	berikut:	Hapus	konten	di	dalam	direktori	manual-
offline-m2/.	Download	kembali	komponen	offline.	Ekstrak	konten	file	ZIP	yang	didownload	ke	direktori	manual-offline-m2/.	Menyertakan	komponen	offline	dalam	project	Gradle	Anda	Untuk	memberi	tahu	sistem	build	Android	agar	menggunakan	komponen	offline	yang	telah	Anda	download	dan	ekstrak,	Anda	perlu	membuat	skrip,	seperti	yang
dijelaskan	di	bawah	ini.	Perhatikan,	Anda	hanya	perlu	membuat	dan	menyimpan	skrip	ini	satu	kali,	meskipun	Anda	mengupdate	komponen	offline.	Buat	file	teks	kosong	dengan	jalur	dan	nama	file	berikut:	Pada	Windows:	%USER_HOME%/.gradle/init.d/offline.gradle	Pada	macOS	dan	Linux:	~/.gradle/init.d/offline.gradle	Buka	file	teks	tersebut	dan
sertakan	skrip	berikut:	def	reposDir	=	new	File(System.properties['user.home'],	".android/manual-offline-m2")	def	repos	=	new	ArrayList()	reposDir.eachDir	{repos.add(it)	}	repos.sort()	allprojects	{	buildscript	{	repositories	{	for	(repo	in	repos)	{	maven	{	name	=	"injected_offline_${repo.name}"	url	=	repo.toURI().toURL()	}	}	}	}	repositories	{	for
(repo	in	repos)	{	maven	{	name	=	"injected_offline_${repo.name}"	url	=	repo.toURI().toURL()	}	}	}	}	Simpan	file	teks.	(Opsional)	Jika	Anda	ingin	memverifikasi	bahwa	komponen	offline	berfungsi	sebagaimana	mestinya,	hapus	repositori	online	dari	file	build.gradle	project	Anda,	seperti	yang	ditunjukkan	di	bawah.	Setelah	mengonfirmasi	bahwa
project	Anda	dibuat	dengan	benar	tanpa	repositori	ini,	Anda	dapat	mengembalikannya	ke	file	build.gradle.	buildscript	{	repositories	{	//	Hide	these	repositories	to	test	your	build	against	//	the	offline	components.	You	can	include	them	again	after	//	you've	confirmed	that	your	project	builds	‘offline’.	//	google()	//	jcenter()	}	...	}	allprojects	{	repositories
{	//	google()	//	jcenter()	}	...	}	Catatan:	Skrip	ini	berlaku	untuk	semua	project	Gradle	yang	Anda	buka	di	workstation.
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